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Introduction
WhistlSort is a program for setting up and performing WhistlSort jobs.

Intended Audience
This User Guide is specifically aimed at end-users of WhistlSort.

Installation
Please see the Hopewiser Software Installation Manual for detailed installation instructions.

Help
WhistlSort includes a full help file facility. This can be accessed by selecting Contents from the Help
menu. Context help is also available for various fields and buttons by pressing F1 when Control is
selected.

Figure 1. About Box

The Help menu also provides access to the About Window. Accessed from the About item, this win-
dow details important information about which version of WhistlSort is running. It is useful to have
these version numbers ready, should technical support be needed, to enable the support staff to provide
the most efficient and effective response.
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1. Main Window
The main window provides the majority of products functionality.

Figure 1.1. Main Window

Please note that the services distributed may differ from the image.

1.1. Menus
Shortcut keys are enabled for most of the menu options. This enables an option to be selected by
pressing the 'Alt' key and a specific letter key. The 'Key' letter is identified by an underscore. To select
the File menu option for example depress 'Alt' and whilst still held down select the 'F' key. Further
shortcuts are available for some options by pressing control key combined with a letter, for example,
'Control + O' loads a setup.

The File Menu provides access to database, setup and print options.

The Settings Menu provides access to mappings screens and the product's preferences.

The Run Menu provides access to the Start Coding option and the Advanced Run Options....

The Tools Menu provides access to the other products packaged with WhistlSort.

The Help Menu provides access to the product Help file and About box.

1.2. Toolbar
The tool bar provides access to some of the common windows used when defining a setup.
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1.3. Service Buttons
The service buttons allow the user to select the service they want to run, for example, Whistl DSA 70.

1.4. Parameters
Parameters are grouped into pages, such as, "General", "Mailing" and "Advanced". The parameters
should be defined as appropriate before starting a run.
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2. Preferences
This window allows the user to select the path where setup files are stored and define to lowest and
highest values to be used for the Mailing Segment.

Figure 2.1. Preferences
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3. Setting Up A File Process

3.1. Selecting A Service
To select a service simply click on the service button with the name of the service you want to run.

3.2. Defining The Parameters
Once the service is selected the user should define the parameters. The parameters are arranged into
pages, such as, General; Mailing and Advanced. The Customer ID and the Item Weight are exam-
ples of parameters. A full explaination of the parameters can be found in whistl_plugins.pdf.

3.3. Input Database
To select a data source for processing, select Input Database from the File menu.

The first stage when opening a database is to select the input database file.

Note
If a database had previously been chosen, the initial file selection window is skipped.

Select the input database type from the Files of type list and either browse the hierarchy to obtain the
input database file name or enter it directly into the text box. Once entered, click the Open button
to proceed.

Figure 3.1. Select Input Database - File Selection
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An alternative is to import the input database details directly from an existing Hopewiser Setup file.
This method allows a database to be passed between Hopewiser software products without having to
re-specify any parameters. Select the Import From Hopewiser Setup type, enter the file name and click
the Open button. The application will then prompt the user to identify the applicable database.

Figure 3.2. Select Input Database - Import

Select the database from the list provided and click the OK button to proceed.

Figure 3.3. Configure Input Database

To exit this window without saving changes click Cancel. To exit this window and save changes click
OK. Alternatively, clicking Apply will save the changes without closing the window.

If the input file is a text file and contains a header record (i.e. field names) then this should be signified
by selecting the Header Record check box. The field delimiter should also be set by selecting either
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the Comma, Tab or Other radio button. Selecting Other enables the user to enter an alternative field
delimiter.

When either a Fixed Record File or Line Sequential File type has been selected a Define button is
displayed. This invokes the Define Fields Window, allowing the user to provide the field definitions.

For all input file types, a View button is displayed. This button allows the user to view the contents
of the input file by invoking the database viewer.

Clicking the Select Different Database... button displays the File Selection window, allowing the
user to choose an alternative file type and name.

Once happy with the choice of input database, click Apply or OK.

3.3.1. Fixed Field Definition
The Define Fields window allows you to set the record length and locate your fields in either a Fixed-
Record format file or a Line-Sequential file.

Figure 3.4. Fixed Field Definition

The window consists of five areas - the graphical representation of the data is at the top. The three boxes
underneath allow you to move through the records (Navigation), define and delete field definitions
(Field Commands) and set the Record Length, either by typing it in, or by use of the Spin Control
buttons. Finally, there is a grid which contains all the current field definitions.

If you click and drag in the graphical area, a new field will be defined. If you click within a field you
may drag it left or right along the record. If you click near to the right of the field name you will be
able to resize it by dragging.
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Fields can be named or manually sized by entering values in the grid section of the window. You may
use the Add button to create a new default field to be edited.

The creation of a Fixed Field or Line Sequential output file requires the user to simply select the file
name and type in the standard Windows file selection screen. There is no requirement to individually
define what will be the recipient output field. These will be defined once the user has 'mapped' the
output fields they want to see in their output database.

3.4. Output Database
The selection of an output database is identical to the selection of an input database. Thus, the user
will be presented with the following window :-

Figure 3.5. The Select Output Database Window

The user now selects the desired file name, and the file type, and then selects Save. The following
window will then be displayed :-
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Figure 3.6. The Configure Output Database Window

Field names can be written to Delimited Text Files as the first record of the output database by checking
the Header Record option.

An additional option on this screen is Quote all fields. If this is selected then all the fields written to
output will be wrapped in double quotes (" ").

Once happy with the choice of output database, click OK or Apply. To cancel any selections made,
click Cancel.

3.5. Input Mappings
Once an input database has been loaded , the next stage is to complete input field linking. This involves
identifying from the input database the fields required to perform the job.
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Figure 3.7. Input Mappings

The Input database fields box lists the fields available from the input database. These have to be
mapped to the Required Fields, which are the inputs that are required to perform the job. Generally
the input address should be mapped and perhaps the DPS.

To save the selection made, click Apply or OK. To cancel any selections made, click Cancel.

3.5.1. Input Fields
For an explaination of the "Available Fields" see whistl_plugins.pdf.

3.5.2. Establishing A Link
A link can be established by highlighting the appropriate item in each list and clicking the Link button.

It is possible to link a group in one list to a group in the other list, thus making several connections
in one go. This is done as follows:

- Highlight all the input database fields you want to link (use the shift key in conjunction with the
mouse).

- Highlight the required field item that you want to link the first highlighted input database field to.
Click the Link button and the first highlighted input database item will be linked to the highlighted
required input; the second highlighted input database item will be connected to the next required field;
and so on.

- Items in each list are marked with an asterisk when they are linked. Highlight a field to find out
which other field it is linked to. The box underneath the lists labelled 'Maps To' for the input database,
and 'Maps From' for the Fields required display the field relationships.

Note
An input database item can be connected to more than one required input. However a
required input can only be connected to one input database item.

To assist in the linking process the input database can be viewed by clicking the View button. (See
Appendix B, Database Viewer.)
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3.5.3. Breaking A Link

The Unlink buttons will unlink mappings from the field(s) selected in their respective lists.

3.6. Output Mappings

Figure 3.8. Output Mappings

To save the selection made, click Apply or OK. To cancel any selections made, click Cancel.

3.6.1. Adding Fields

Select the required fields by highlighting the field and clicking Add. As fields are selected they will
appear in the Output list. When fields are added they are automatically linked and marked in each
list with an asterisk when they are linked. Highlight a field to find out which other field it is linked
to. The box underneath the lists (labelled 'Links To' for the input database, and 'Links From' for the
Fields required) display the field relationships.

Entire categories can also be added by selecting a category name and clicking Add.

Note
Multiple fields can be selected by holding the CTRL button down on the keyboard and
clicking on the required fields. To select a range of fields (e.g. Label lines) click on the
first field, hold down the SHIFT key on your keyboard and click the last field required.

3.6.2. Removing Fields

To Remove a field simply select its entry in the Output list and click the Remove button, or dou-
ble-click on the item.
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3.6.3. Re-linking Fields
For the purpose of breaking and establishing links the Link and Unlink buttons are provided. The
Unlink buttons will unlink mappings from the field(s) selected in their respective lists. To link fields
select the fields to link and click the Link button to make the connection.

3.6.4. Auto Linking
Clicking the Auto button will link output fields to their input/generated fields of the same name, if not
already linked. If no fields are in the output, all generated and input fields will be added to the output.

3.6.5. Setting A Key
Clicking the Set Key button will set a primary key on the selected output field. Only a single key may
be selected (use Set Key again to unset), and it will only affect non-text databases.

Note
An ODBC database will require a primary key for writing. A primary key must be unique
over all data. WhistlSort does not provide a mechanism to generate such a key since it is
expected that an ODBC output will have been generated from an ODBC input source.

3.6.6. Moving Fields
The order of the output fields can be changed by highlighting the required field and using the up and
down arrows on the right of the window. Users will not be able to move fields if the output database
already exists and is being appended to.

3.6.7. Renaming Fields
In the case of two fields in different categories such as 'Input Fields' and 'Generated Fields' having the
same name, if users want to add both into the Output list, they will be asked to rename one of the fields.

3.6.8. Multilinking Fields
Any input field can be linked to more than one output field. If one input field is linked with two output
fields, two asterisks will be added next to this input field. If the user highlights this input field the
'Links To' list will show two linked output fields.
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4. Starting A Run
Once all the setup stages have been completed the database can be processed. To start the run select
Start Run from the Run menu, or click the start icon on the toolbar. WhistlSort will process the entire
file without stopping. An incremental count of records processed is displayed in the Run Information
Window. It is possible to stop the run at any time by clicking the Stop Button.

4.1. Run Information
Figure 4.1. Run Information

This window keeps the user informed with some useful statistics whilst the job is running. The Stop
button stops the run.
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5. Reports
The Reports of a run can be viewed by selecting View from the View menu, and then the type of report
you wish to view. To exit the Reports click the Close button. To print the report click the Print button
which will open the standard print dialogue. The << and >> buttons can be used to move back and
forward through the Statistics report. A drop-down box is also included to set the zoom percentage
when viewing the statistics.

5.1. Exporting Reports
The WhistlSort Reports can be exported to a text file by selecting Export and then the type of report
you wish to export from the View menu.
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Appendix A. Command Line Options
It is possible to alter the behaviour of the product by executing from a command prompt with 'command
line options'. These options are especially useful when running the product as part of an automated
batch job. For example, a user can load a setup, run the job and export reports all from one command.

Options

Option: --nosplash
Description: Start without a splash window.
Option: -a, --autorun
Description: Start run automatically.
Option: --autoruntool
Description: Run tool.
Option: -h, --hide
Description: Start program with window minimized.
Option: -d, --die
Description: Exit after run completion.
Option: -f, --deffile
Description: Load the specified service file only.
Option: --reportdir
Description: Directory to export reports to.
Option: --reportprefix
Description: Prefix added to reports.
Option: -r, --repfile
Description: File name for Computer Planning report.
Option: -l, --linelisting
Description: File name for Line Listing report.
Option: --showlocked
Description: Show unlicensed services.

A.1. Examples
Start the product and load setup file: mysetup.hpw.

whistlsort.exe mysetup.hpw.

Run the product with the plugin specified, load the setup and start run.

whistlsort.exe --deffile 1400.def --autorun mysetup.hpw

Run the product, load the setup, start run and export the reports to "c:\reports" directory.

whistlsort.exe --autorun --report c:\reports mysetup.hpw

Note
When "--autorun" is selected a log file is created, whistlsort.log, describing the job.
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Appendix B. Database Viewer
The Database Viewer enables the user to view the contents of either an input or an output database. It
can be accessed from any program using the 'View' button on the appropriate database selection screen.

The window comprises a Database Browsing area, a Data panel, an Options panel and a Navigation
panel. The Navigation panel shows the total number of records in the database.

The Database viewer has two viewing states: Single-record view and Multi-record view.

Single-Record View
This is the default setting of the database viewer. In this state the user is presented with two columns,
one of which lists the field names, and the other the field values, as shown below.

Figure B.1. Database Viewer - Single Record View

The field name is that specified for each field in the database. If field names are not included in
the database then the fields will be listed Field1, Field2, etc. Field Value lists an individual record's
contents for those fields.

The records can be viewed one at a time, using the '<' and '>' buttons to move backwards and forwards
through the database. Alternatively, the user can enter the number of the required record to jump to
within the edit box. If the specified record exists it will be displayed. If the record does not exist the
last record within the file will be displayed. The '<<' and '>>' buttons will move through the database
a page at a time and the '[<<' and '>>]' buttons will move to the start and end of the file respectively.
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The cell widths can be adjusted by dragging the column separators in the title row. This enables better
viewing of the contents of a particular cell. However, if you then continue to move through the file the
cell will revert back to the original size. To maintain the cell sizes select the Lock Cell Sizes check box.

Clicking the Close button will exit the Database viewer.

Multi-Record View
The Database Viewer can be set to grid details by selecting Multi-record View. In this state it displays
the contents of the database in a grid, as shown below :-

Figure B.2. Database Viewer - Multi-Record View

The field names are displayed in the title row, and each record is subsequently displayed in a separate
row, the record number being listed in the column on the left of the grid.

As with single record view the cell widths are again lockable by selecting the Lock Cells Sizes check
box. The Navigation Panel as detailed in the single record view is also available for moving through
the database.

Using the cursor it is possible to highlight particular fields, records and cells. A single click will
highlight a field's contents. A double-click will change the Database Viewer to a single record view
with focus on your selected record. Once you have viewed the record you can move back to the
multi-records view by double-clicking within the details of the record in focus.

Again, clicking the Close button will exit the viewer.



Database Viewer

17

Hexadecimal Reader
Both single and multi record states contain a hexadecimal reader under the heading Data. When you
click on the field this displays the contents of the field represented as hexadecimal data. This is useful
when trying to ascertain the exact contents of a field.
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Appendix C. Setups
A Setup is a collection of all the information you enter at each step in order to define a run. It is useful
to save this information so that it will be available each time you use the program; you will not need
to re-enter all steps to repeat the same input/output process. It is worth saving the information even if
you do not intend to do exactly the same run again, because it may be easier to re-load the information
and make a few changes than to start from scratch again.

Saving a Setup
To save a setup select Save Setup from the File menu, which will invoke the 'Save Setup' dialogue.
Enter a name and location for the setup.

If you make changes to a setup, and save it again (without renaming it) you will overwrite the original
saved setup. If you want to retain both the original version and the edited version save the edited
version under a new name by selecting Save Setup As... from the File menu.

Loading a Setup
To load a setup select Load Setup from the File menu, which will invoke the 'Load Setup' dialogue.
Select the required setup file. Provided that the original input/output files can be found, the program
will be ready to repeat the run. You can also make changes to the setup information as if you had just
started from scratch and gone through all the required steps.

If you select a setup and the original input file cannot be found (or the fields used by the setup no
longer exist) you will need to select another input file before you can run, or edit the setup. When you
select a new input database the program will check whether it contains the fields required by the setup,
and offer the choice of selecting another file or abandoning the setup, if it does not. However, the only
check made is that fields of the right type can be found in the right position (e.g. that there is a field
10 and it is a text field) so you must also check that the new input file contains the correct fields.

If you select a setup and the original output file cannot be found you will have to select another output
file. If the original file can be found but the fields used by the setup no longer exist, you will need to
select another file or overwrite the table.

If any of the database or mapping windows have been altered by the user, the user will be given the
option to save the setup when they exit the application.
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Appendix D.  Whistl Plugins
For an explanation of the database inputs and outputs, parameters and and reports created see
whistl_plugins.pdf..
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Appendix E. WhistlSplit
WhistlSplit is a product that allows the user to split the output files from WhistlSort into direct and
residue files.

Figure E.1. WhistlSplit

The following files are split into a direct file and a residue file with STL items.

• Output Database

• .tnt Upload File

• Bag File

• Production File

Note that output files from Walksort will not be split. The user can optionally choose to delete the
original output files once they have been split, note that the output database will not be deleted.

E.1. Output Database
The file name will be prefixed with either "Direct_" or "Residue_". For example, "out.txt" will be split
into "Direct_out.txt" and "Residue_out.txt".

E.2. .tnt Upload File
The file name will be prefixed with either "Direct_" or "Residue_". For example, 000000000.tnt will
be split inot "Direct_000000000.tnt" and "Residue_000000000.tnt".
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E.3. Whistl Bag File
The first character of the bag file name will be replaced by either a "D" for the direct file or "R" for
the residue file. For example, 0000000.bag will be split into D0000000.bag and R0000000.bag.

E.4. Whistl Production File
The file name will be prefixed with either "Direct_" or "Residue_". For example, 00000000.prd will
be split inot "Direct_00000000.prd" and "Residue_00000000.prd".

E.5. User Requirements
For the output database to be split, the WhistlSort user must do the following:

• Set the output database as a "Delimited Text File".

• Set the output database to have a "Header" record.

• Map the "Sortation" field to the output database.

E.6. Invocation
WhistlSplit can be run from within WhistlSort after a job has finished. When run from within
WhistlSort the necessary parameters are automatically populated.

E.7. Command Line
The following command line arguments are supported :-

Command Line Options

Option: -o
Meaning: The output database file name.
Option: -d
Meaning: The output database field delimiter.
Option: -q
Meaning: Indicate if the output database fields are quoted.
Option: -t
Meaning: The .tnt Upload file name.
Option: -b
Meaning: The bag file name.
Option: -p
Meaning: The production file name.
Option: -a
Meaning: Automatically start the run whe the program starts.
Option: -x
Meaning: Indicate if the original files should be deleted (1 to delete, 0 NOT to delete).
Option: -i
Meaning: Automatically close WhistlSplit when a run the is complete.

An example command line follows:  whistlsplit.exe -o c:\outdata\out.txt -d "," -q 1 -r c:\outda-
ta\0000000TB.tnt -b c:\outdata\00000TB.bag -p c:\outdata\000000TB.prd -a -x 1
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Appendix F. WhistlSort Bag Labeller
The "WhistlSort Bag Labeller" is an application that allows the user to print bag and tray labels.

Figure F.1. WhistlSort Bag Labeller

Use the bag file created by WhistlSort as the input. The program can be launched from within
WhistlSort and the bag file will be loaded automatically ready to print the labels.

The "Page Layout" will display the selected type of label on the current printer.

The "Page margins" are displayed as a black dotted rectangle.

The "Label margins" are displayed as a solid grey rectangle.

The "Number of Labels" is the number of labels to be printed on the selected paper.

F.1. Open File
The "File Open" dialogue allows the user to select and open a WhistlSort bag file.
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F.2. Print Preview
The "Print Preview" dialogue displays the WhistlSort bag file labels.

The user can navigate through the labels.

F.3. Print
The "Print" dialogue is used to print the labels.
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The following information will be displayed:

• The selected printer.

• The bag file to be printed.

• The type of label, Bag or Tray.

The user can set the following:

• Print all the labels.

• Only print a range of labels.

• The number of copies.

F.4. Reset Values
The "Reset Values" menu option resets the Page margins, Label margins and number of labels.

F.5. Collection Date
The "Collection Date" dialogue allows the user to set the collection date.
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The collection date defaults to the current date, but can be set to any date.

F.6. Preferences
The "Preferences" dialogue allows the user to set the print preferences.

The data files path should be set to the database location.

The labels type should be set to Bag or Tray labels. This must match the type of label in the printer.

The print a blank label option is used to indicate when the depot has changed.

The font is the font used when printing barcodes on the labels.

F.7. Help About
The "Help About" dialogue the version numbers of the components that make up the WhistlSort bag
labeller.

Should any issues be found with the WhistlSort bag labeller these version numbers should be included
in the document.
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Appendix G. Known Issues
Known issues and bugs with the current release of WhistlSort.

G.1. Input Files with Headers
Input files with a header line are limited to 1024 characters in that header. Any files with a header
longer than this will not load.
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